Canonical soluciona una grave vulnerabilidad en el kernel de Ubuntu

SOURCE: Noticias de seguridad informática http://noticiasseguridad.com/vulnerabilidades/canonical-soluciona-una-grave-vulnerabilidad-en-el-kernel-de-ubuntu/
TAGS: Canonical, Ubuntu
Durante mucho tiempo, los sistemas operativos alternativos a Windows, como macOS o Linux, han permanecido seguros y protegidos frente a los incesantes ataques informáticos que les llegaban, tanto localmente como a través de Internet. Sin embargo, las técnicas de ataque han cambiado en los últimos años y, debido a una programación descuidada de distintos complementos, cada poco tiempo aparecen vulnerabilidades en estos dos sistemas que deben ser solucionadas para poder garantizar la máxima seguridad a los usuarios.

Hace algunas horas, Canonical publicaba un nuevo boletín de seguridad de Ubuntu en el que informaba de una vulnerabilidad bastante grave que afecta a todas las versiones del Kernel de Ubuntu. Esta nueva vulnerabilidad ha sido registrada como CVE-2017-7184 y se encuentra presente en el framework xfrm del sistema operativo, framework encargado de validar los datos recibidos en el espacio de usuario.

Debido a este fallo, un atacante podría generar un ataque DoS contra el sistema, desactivando este framework y causando un bloqueo general del sistema, o lo que es más peligroso, ganar permisos en el mismo para lograr ejecutar código con permisos de root al poder acceder fuera de los límites de la memoria utilizando los vectores adecuados.

Canonical no ha confirmado la versión mínima de Ubuntu afectada por esta vulnerabilidad, pero lo que sí ha publicado es que todas las versiones que actualmente tienen soporte, desde Ubuntu 12.04 LTS, son vulnerables y, eso sí, ya cuentan con su correspondiente parche de seguridad.

Las versiones vulnerables y actualizadas son:

  • 12.04 LTS – actualizada a la versión linux-image 3.2.0.125.140.
  • 14.04 LTS – actualizada a la versión linux-image 3.13.0.115.125
  • 16.04 LTS – actualizada a la versión linux-image 4.4.0.71.77
  • 16.10 – actualizada a la versión linux-image 4.8.0.45.57.

Cuando llegue el nuevo Ubuntu 17.04 el próximo mes de abril, esta vulnerabilidad ya vendrá solucionada directamente al incluir los últimos parches de seguridad del kernel.

Para actualizar y proteger de nuevo nuestros sistemas, lo único que debemos hacer es ejecutar desde un terminal los siguientes comandos para descargar las últimas actualizaciones disponibles:

  • sudo apt update
  • sudo apt dist-upgrade

Además de estas vulnerabilidades en el kernel, Canonical ha publicado una serie de vulnerabilidades en Chromium que puede permitir a un atacante alterar los resultados de una página web o evadir las medidas de seguridad del sistema operativo, poniendo en peligro a los usuarios.

Podemos encontrar más información sobre estas vulnerabilidades en el portal de seguridad de Canonical.

Ubuntu 12.04 dejará de tener soporte en breve. Llega el fin de la LTS

El próximo 28 de abril de 2017, la ya anticuada versión de este sistema operativo, Ubuntu 12.04, dejará de tener soporte tras cumplir sus 5 años de soporte LTS prometidos. Tras dicha fecha, este sistema dejará de recibir parches y actualizaciones, salvo que los usuarios que quieran den el salto a la nueva versión Extended Security Maintenance (ESM).

Aprovechando el fin de soporte, la compañía quiere aventurarse en un nuevo modelo de negocio basado en soporte premium con las nuevas versiones ESM, y es que seguirá ofreciendo parches y actualizaciones de seguridad a los usuarios que aún utilicen esta versión LTS, eso sí, a cambio de una cuota anual nada barata: 150 dólares por cada servidor al que dar mantenimiento.

Si aún no sois usuarios de Ubuntu, desde RedesZone os recomendamos, por comodidad, instalar la versión LTS más reciente, en estos momentos 16.04, ya que nos garantiza soporte hasta abril de 2021 y no nos obligará a actualizar cada 9 meses a una nueva versión como obligan las versiones estándar.

Fuente: https://www.redeszone.net/
Noticias de seguridad informática http://noticiasseguridad.com/vulnerabilidades/canonical-soluciona-una-grave-vulnerabilidad-en-el-kernel-de-ubuntu/

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s